Jump to content


Photo

Cgminer thread concurrency setting!

thread concurrency mincoin

  • Please log in to reply
8 replies to this topic

#1 m5city

m5city

    MinNewb

  • Members
  • Pip
  • 3 posts

Posted 29 December 2013 - 08:03 AM

hi, i'm new to Mincoin, i just stated working on it today!

 

im mining with 3X R9 290, i used to mining litecoin and some others, i use same sitting for all of them , but today i keep getting Error -4 on cgminer, it is saying my thread concurrency is too high, i got no idea for this. my setting worked for all other coins, why not Mincoin? can anyone help?

 

here is my setting:

 

 -I 20 -g 1 --worksize 512 --thread-concurrency 27400 --gpu-powertune 20 --gpu-engine 960 --gpu-memclock 1250 --lookup-gap 2 --gpu-platform 0 --gpu-fan 75

 

thanks! :)
 



#2 CC66

CC66

    Moderator

  • Moderators
  • 301 posts
  • Locationhttps://mincoin.us

Posted 29 December 2013 - 05:03 PM

Try adding these commands to the beginning of your cgminer  .bat file.  The first one should solve the issue you're having allowing higher --thread-concurrency

 

setx GPU_MAX_ALLOC_PERCENT 100 
setx GPU_USE_SYNC_OBJECTS 1


#3 m5city

m5city

    MinNewb

  • Members
  • Pip
  • 3 posts

Posted 30 December 2013 - 03:16 AM

 

Try adding these commands to the beginning of your cgminer  .bat file.  The first one should solve the issue you're having allowing higher --thread-concurrency

 

setx GPU_MAX_ALLOC_PERCENT 100 
setx GPU_USE_SYNC_OBJECTS 1

 

 

yes i have this on my BAT file!



#4 CC66

CC66

    Moderator

  • Moderators
  • 301 posts
  • Locationhttps://mincoin.us

Posted 30 December 2013 - 04:04 AM

yes i have this on my BAT file!

First delete the old .bin files. Then run the .bat file without --thread-concurrency xxxxx  

cgminer will try and find the TC that's right for your card.   

 

In the cgminer folder look for the new .bin file created that looks something like this

 

scrypt130511Tahitiglg2tc22400w256l4.bin

 

the number after the "tc" is the thread concurrency that should work for your card.    On my 280x I use   --thread--concurrency 22400



#5 m5city

m5city

    MinNewb

  • Members
  • Pip
  • 3 posts

Posted 30 December 2013 - 05:59 AM

First delete the old .bin files. Then run the .bat file without --thread-concurrency xxxxx  

cgminer will try and find the TC that's right for your card.   

 

In the cgminer folder look for the new .bin file created that looks something like this

 

scrypt130511Tahitiglg2tc22400w256l4.bin

 

the number after the "tc" is the thread concurrency that should work for your card.    On my 280x I use   --thread--concurrency 22400

 

thank you , i also did this, my 290 is scrypt130511Hawaiiglg2tc30592w256l4,   30592 won't give me best result,  but 27400 did!

 

i just don't know why this setting working for litecoin, feathercoin and any others,just  not working for mincoin pool, also i find it not working for some dogecoin pool! these pools have only around 10m hashrate!



#6 LongAndShort

LongAndShort

    Member

  • Members
  • PipPipPipPipPipPipPipPip
  • 138 posts
  • LocationMelbourne

Posted 05 January 2014 - 11:11 AM

......... -I 20 -g 1 --worksize 512 --thread-concurrency 27400 --gpu-powertune 20 --gpu-engine 960 --gpu-memclock 1250 --lookup-gap 2 --gpu-platform 0 --gpu-fan 75

 

Usually lookup gap plays a part with tc issues but this is my line for 290x dont know if it will help but its a try its a sweet spot i get about 845kh..i have higher temps atm because i want it to be quiet but its safe at that level it just uses more power cause power gets dispersed by way of heat if you don't mind noise keep ur fan at 75 imo..hope it helps

 

 -I 20 -g 1 -w 512  --auto-fan --temp-target=85 --temp-overheat 92 --thread-concurrency 32765 --lookup-gap 2 --expiry 1 -s 1 --no-submit-stale --queue 0 --gpu-engine 880 --gpu-memclock 1375 --gpu-powertune 20 


“Those who surrender freedom for security will not have, nor do they deserve, either one.”
- Benjamin Franklin

#7 ubm

ubm

    MinNewb

  • Members
  • Pip
  • 3 posts

Posted 25 January 2014 - 04:55 PM

scrypt130511Tahitiglg2tc22400w256l4.bin

 

 

 

wouldn´t w256 stand for worksize 256 ? just out of curiosity ...

that would mean

worksize 256,

thread concurrency 30592

and lg2 for lookup-gap 2

________________________________

with worksize 512

should n´t it be 

thread concurrency 15296

lookup-gap 1



#8 LongAndShort

LongAndShort

    Member

  • Members
  • PipPipPipPipPipPipPipPip
  • 138 posts
  • LocationMelbourne

Posted 25 January 2014 - 10:16 PM

Older cards you used to have to play with lookup-gap but 290 is safe to just use lookup-gap 2 and if its not in the batch file or conf then it will automatically set 2

 

His/her TC dosn't make sense TC should be around 12x shader clock, which for 290 (no x) is 2560 and should be in multiples of that number to be optimal.

 

worksize should be fine at 512 for a few 290 cards but will prolly be better to be used in this formula.

250KH and below: 16
250+: 32
500+: 64
1000+: 128
2000+: 256
3000+: 384
4000+: 512 

To me his/her ultimate settings would be  -I 20 -g 1 --worksize 256 --thread-concurrency  30720 

 

If he/she is still having errors could be a lack of ram issue (even though it worked for one coin but not another. Its weird and i have found weird phenomona in this regard)


“Those who surrender freedom for security will not have, nor do they deserve, either one.”
- Benjamin Franklin

#9 CC66

CC66

    Moderator

  • Moderators
  • 301 posts
  • Locationhttps://mincoin.us

Posted 18 April 2014 - 10:03 PM

Here's one of the couple version's of cgminer I've been keeping up with.

You can usually find the dev on irc or gtihub ;)

 

 

http://k-dev.net/cgminer/






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users