Jump to content


Photo

Is Anyone Working on the Wallet?


  • Please log in to reply
7 replies to this topic

#1 headzoo

headzoo

    MNC Dev Team

  • Members
  • PipPipPipPipPipPip
  • 73 posts

Posted 31 December 2013 - 06:11 PM

So I've noticed the MinCoin wallet/daemon is several versions behind the Litecoin software from which it was forked. It also appears no new commits have been added to the software in 2 months, and before that single commit it's been 9 months.

 

Now I'm seeing this error coming from the wallet, "Mandatory upgrade to Litecoin 0.8.6.1+. https://litecoin.org/upgrade". Which means:

 

* May not be applicable to MinCoin, and should just be ignored.

* Someone should change the error message to say "MinCoin" instead of "Litecoin".

* Is possibly a sign the software needs some critical fixes.

 

It's also not a good sign when the developers have disabled the Github issue tracker. It's a bit like hanging up a "Do Not Disturb" sign.

 

Little things like this really bring down the perceived value of MinCoin, at least among developers.



#2 SuperTramp

SuperTramp

    The Boss

  • Administrators
  • 601 posts
  • Location: Planet MinCoin

Posted 01 January 2014 - 02:32 AM

So I've noticed the MinCoin wallet/daemon is several versions behind the Litecoin software from which it was forked. It also appears no new commits have been added to the software in 2 months, and before that single commit it's been 9 months.

 

Now I'm seeing this error coming from the wallet, "Mandatory upgrade to Litecoin 0.8.6.1+. https://litecoin.org/upgrade". Which means:

 

* May not be applicable to MinCoin, and should just be ignored.

* Someone should change the error message to say "MinCoin" instead of "Litecoin".

* Is possibly a sign the software needs some critical fixes.

 

It's also not a good sign when the developers have disabled the Github issue tracker. It's a bit like hanging up a "Do Not Disturb" sign.

 

Little things like this really bring down the perceived value of MinCoin, at least among developers.

 

What MNC QT version are you running?


MinCoin, The #1 Crypto-Commodity


#3 headzoo

headzoo

    MNC Dev Team

  • Members
  • PipPipPipPipPipPip
  • 73 posts

Posted 01 January 2014 - 02:54 PM

What MNC QT version are you running?

 

Technically I'm not using the QT version, as I'm running mincoin as a daemon on my web hosting server. I compiled from the sources on Github, which is linked from the main MinCoin website.



#4 headzoo

headzoo

    MNC Dev Team

  • Members
  • PipPipPipPipPipPip
  • 73 posts

Posted 02 January 2014 - 02:35 AM

Just to add a bit of information, here is my output from getinfo:

 

{
    "version" : 60400,
    "protocolversion" : 60002,
    "walletversion" : 60000,
    "balance" : 18.44974475,
    "blocks" : 287474,
    "connections" : 6,
    "proxy" : "",
    "difficulty" : 2.34968269,
    "testnet" : false,
    "keypoololdest" : 1387839431,
    "keypoolsize" : 101,
    "paytxfee" : 0.00000000,
    "mininput" : 0.00010000,
    "errors" : "Mandatory upgrade to Litecoin 0.8.6.1+.  https://litecoin.org/upgrade"
}


#5 Chicago

Chicago

    MinCoin Master

  • Moderators
  • 62 posts
  • LocationFEMA Region V

Posted 03 January 2014 - 01:48 PM

 

Just to add a bit of information, here is my output from getinfo:

 

{
    "version" : 60400,
    "protocolversion" : 60002,
    "walletversion" : 60000,
    "balance" : 18.44974475,
    "blocks" : 287474,
    "connections" : 6,
    "proxy" : "",
    "difficulty" : 2.34968269,
    "testnet" : false,
    "keypoololdest" : 1387839431,
    "keypoolsize" : 101,
    "paytxfee" : 0.00000000,
    "mininput" : 0.00010000,
    "errors" : "Mandatory upgrade to Litecoin 0.8.6.1+.  https://litecoin.org/upgrade"
}

 

Try using this github repository instead. https://github.com/vipah/mincoin.git

It should report, "version" : 60500



#6 headzoo

headzoo

    MNC Dev Team

  • Members
  • PipPipPipPipPipPip
  • 73 posts

Posted 03 January 2014 - 10:09 PM

Try using this github repository instead. https://github.com/vipah/mincoin.git

It should report, "version" : 60500

 

That seems to have fixed things. Thanks!



#7 -Jt

-Jt

    MNC Dev Team

  • Moderators
  • 140 posts

Posted 05 January 2014 - 01:40 PM

That seems to have fixed things. Thanks!

 

We really need to get all these loose MNC pieces in order (ie. Wallet versions/repos, website, coin details (which were changed)... Having these things all over the place make it hard to use MNC.

 

As part of this new work to develop a new face of Mincoin, we should also to focus on consolidating and updating all MNC resources.


  • SuperTramp likes this
MNC Donations Accepted: MEfCq4U68vBaXP2B9ACAKaHAfRueYxDQhE

#8 veremit

veremit

    MNC Dev Team

  • Members
  • PipPip
  • 13 posts
  • LocationUK

Posted 08 January 2014 - 08:23 PM

I'm up for joining the wallet project .. all the things in this thread make sense to me .. so, let's make it happen! :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users